]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - test/package/debian-mingw/rules
ncurses 6.2 - patch 20200321
[ncurses.git] / test / package / debian-mingw / rules
index dce21a116234bba3ce11946efc25216f84f7cb8d..e61cf71a3fa3ded0e39bcffc3e8f014a0f213d8f 100755 (executable)
@@ -1,5 +1,5 @@
 #!/usr/bin/make -f
-# MAde with the aid of dh_make, by Craig Small
+# Made with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Cristoph Lameter.
 
@@ -14,6 +14,8 @@ DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 CC_NORMAL = -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wconversion
 CC_STRICT = $(CC_NORMAL) -W -Wbad-function-cast -Wcast-align -Wcast-qual -Wmissing-declarations -Wnested-externs -Wpointer-arith -Wwrite-strings -ansi -pedantic
 
+NCURSES_PKG = ncurses-examples
+
 TARGET    = i686-w64-mingw32
 MINGW_BIN = /usr/bin
 MINGW_TOP = /usr/$(TARGET)
@@ -39,6 +41,8 @@ configure-stamp:
                --host=$(TARGET) \
                --target=$(TARGET) \
                --prefix=$(MINGW_TOP) \
+               --bindir=\$${prefix}/bin/$(NCURSES_PKG) \
+               --datadir=\$${prefix}/share/$(NCURSES_PKG) \
                --with-screen=ncursesw6 \
                --with-pkg-config-libdir=/usr/$(TARGET)/lib/pkgconfig