]> ncurses.scripts.mit.edu Git - ncurses.git/blob - test/package/ncurses-examples.spec
70b51a97734b6263f5fa7690f6736f654ffb000b
[ncurses.git] / test / package / ncurses-examples.spec
1 Summary: ncurses-examples - example/test programs from ncurses
2 %define AppProgram ncurses-examples
3 %define AppVersion MAJOR.MINOR
4 %define AppRelease YYYYMMDD
5 # $Id: ncurses-examples.spec,v 1.6 2017/08/11 00:12:20 tom Exp $
6 Name: %{AppProgram}
7 Version: %{AppVersion}
8 Release: %{AppRelease}
9 License: MIT
10 Group: Applications/Development
11 URL: ftp://invisible-island.net/%{AppProgram}
12 Source0: %{AppProgram}-%{AppRelease}.tgz
13 Packager: Thomas Dickey <dickey@invisible-island.net>
14
15 %description
16 These are the example/test programs from the ncurses MAJOR.MINOR distribution,
17 for patch-date YYYYMMDD.
18
19 This package installs in "bin/ncurses-examples" to avoid conflict with other
20 packages.
21 %prep
22
23 %setup -q -n %{AppProgram}-%{AppRelease}
24
25 %build
26
27 INSTALL_PROGRAM='${INSTALL}' \
28         ./configure \
29                 --target %{_target_platform} \
30                 --prefix=%{_prefix} \
31                 --bindir=%{_bindir}/%{AppProgram} \
32                 --datadir=%{_datadir}/%{AppProgram} \
33                 --with-screen=ncursesw6 \
34                 --disable-rpath-hack
35
36 make
37
38 %install
39 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
40
41 make install               DESTDIR=$RPM_BUILD_ROOT
42
43 strip $RPM_BUILD_ROOT%{_bindir}/%{AppProgram}/*
44
45 %clean
46 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(-,root,root)
50 %{_bindir}/%{AppProgram}/*
51
52 %changelog
53 # each patch should add its ChangeLog entries here
54
55 * Thu Mar 25 2010 Thomas Dickey
56 - initial version